skip to Main Content

Microsale Security Update

TouchSuite will perform this update during afterhours on your POS system. If you do not want us to perform this update, please notify us by calling 800-793-3250, option 2.

Update Process:

Our terminal specialists will be performing the update for you. To ensure a seamless process, we ask that you verify you have TouchSuite version 8.0.2700 or higher installed on your POS. This update will be performed remotely and will not affect your transactions during business hours. After the completion of the TLS 1.2 update, you will meet PCI council compliance.

Frequently Asked Questions: 

Why is updating important?

Payment security measures are constantly evolving. Maintaining the latest version of TLS protocol is essential in safeguarding your customers data. TLS 1.2 is a mandatory update that must be completed to stay PCI compliant.

What is TLS 1.2?

Used widely online, TLS is a cryptographic protocol used to establish a secure communication channel between two systems. It is used to authenticate one or both systems, and protect the confidentiality and integrity of information that passes between systems. Due to this, it is urgent that all merchants upgrade to the most current version of TLS (Version 1.2). In compliance with PCI direction, Datawire will be disabling all non-compliant SSL and TLS protocols on February 18, 2018 as this is a measure to protect the data safety of you and your customers.

When is the update deadline?

In compliance with PCI council, Datawire will be disabling all non-compliant SSL and TLS protocols on February 18, 2018 as this is a measure to protect the data safety of you and your customers. If you do not update your terminal by this date, you may experience a service outage and will not be able to process transactions until the update is performed.

How do I update to TLS 1.2?

Our terminal specialists will be performing the update remotely and pushing it to your POS system afterhours. The update will be completed by open of business the next day. If you experience any issues, please contact support directly by calling 800-793-3250, option 2.

Do I need to prepare anything before the update?

To ensure a seamless update process, please have TouchSuite version 8.0.2700 or higher installed on your POS.

Contact Us

If you experience any issues after the update or have questions our team is here to help. Contact us by initiating a chat, calling our operations department directly at 800-793-3250 option 2 or fill out the form below and a member from our support team will reach out to you shortly!

Top
Search